Campus Services Security Cameras Issues
Incident Report for HUIT
Resolved
Security cameras access are back to normal as of 12pm.
Posted Aug 11, 2020 - 12:10 EDT
Investigating
HUIT is investigating intermittent issues with campus video cameras.
Posted Aug 11, 2020 - 10:42 EDT
This incident affected: Campus Services Applications.