Qualtrics Service Degradation
Incident Report for HUIT
Resolved
The issue was resolved as of 12:40pm.
Access to Qualtrics, Concur, and other few affected applications are restored and back to normal.
Posted Jul 22, 2021 - 12:58 EDT
Investigating
Qualtrics service is currently unavailable. HUIT is aware and actively investigating the problem.
Posted Jul 22, 2021 - 12:16 EDT
This incident affected: Teaching & Learning Platforms (Qualtrics).