HarvardKey Authentication is Degraded
Incident Report for HUIT
Resolved
This intermittent service degradation has been resolved.
Posted Sep 16, 2021 - 13:23 EDT
Investigating
HarvardKey authentication service is degraded at this time. Some users may experience intermittent authentication errors when logging in to HarvardKey applications. Please try logging in again. If repeated attempts still do not let you in, please submit a ticket with the URL of the application you are trying to access to ithelp@harvard.edu.
Posted Sep 16, 2021 - 13:09 EDT
This incident affected: HarvardKey (HarvardKey Authentication).