PeopleSoft Login Troubleshooting
Incident Report for HUIT
Resolved
The PeopleSoft platform is back to normal operations. We apologize for any inconvenience this may have caused.
Posted Sep 14, 2021 - 10:07 EDT
Monitoring
PeopleSoft is experiencing intermittent login issues. HUIT is actively investigating. In the meantime, it is recommended to try using an incognito browser window or clear your browser's cache and cookies.

If you continue to experience issues logging in to PeopleSoft please reach out to the HUIT Service Desk.
Posted Sep 13, 2021 - 15:23 EDT
This incident affected: HR Applications (PeopleSoft).