OpenScholar sites experiencing loading issues.
Incident Report for HUIT
Resolved
This incident has been resolved.
Posted Oct 30, 2020 - 08:20 EDT
Investigating
OpenScholar sites (such as mso.harvard.edu, huit.harvard.edu, fas.harvard.edu, etc.) are currently experiencing loading issues. HUIT is aware of the issue and is actively investigating.
Posted Oct 30, 2020 - 07:46 EDT
This incident affected: Harvard Web Publishing Platform.