Canvas SpeedGrader & Files Degradation
Incident Report for HUIT
Resolved
The Canvas SpeedGrader incident is resolved. Performance has returned to normal for Canvas SpeedGrader Docviewer and Files. Instructure declared this incident resolved after monitoring their implemented fix for about an hour.

https://status.instructure.com/
Posted May 16, 2022 - 15:59 EDT
Update
The initial fix put in place by our vendor was unsuccessful in resolving the issues impacting Canvas SpeedGrader Docviewer and Files. They are currently monitoring a new fix put in place around 1:12PM and will provide us with updates after a period of monitoring.
Posted May 16, 2022 - 13:19 EDT
Monitoring
As of 10:00AM our vendor has implemented a fix to to resolve issues impacting Canvas SpeedGrader and Files, and are monitoring the results.
Posted May 16, 2022 - 10:13 EDT
Investigating
The Canvas SpeedGrader Docviewer is experiencing degraded performance. When trying to view an assignment submission, users receive an error "Service is currently unavailable. Try again later." The Files area is also affected. Files may not render for viewing, though they may upon reload.
Posted May 16, 2022 - 09:48 EDT
This incident affected: Canvas.