Harvard Key Authentication Issues
Incident Report for HUIT
Resolved
Harvard Key Login is restored for all affected applications as of 11:27AM.
Posted Aug 13, 2020 - 12:37 EDT
Investigating
Users reported issues logging into some applications including MID, Qualtrics, and AWS Console using Harvard Key.
HUIT is investigating.
Posted Aug 13, 2020 - 11:17 EDT
This incident affected: HarvardKey (HarvardKey Authentication).