Harvard Yard Wired Network Degradation

Incident Report for HUIT

Resolved

The network issue affecting wired connectivity in The Yard has been resolved. Connectivity has been restored and HUIT will continue to monitor to ensure stability. If you continue to experience issues please contact the HUIT Service Desk via 617-495-7777 or email ithelp@harvard.edu
Posted Sep 04, 2025 - 13:15 EDT

Identified

HUIT is investigating a wired network issue affecting the Yard. A change has been implemented and service is beginning to restore. The team will continue monitoring and investigating to ensure full resolution.
Posted Sep 04, 2025 - 13:01 EDT
This incident affected: Network Services (Wired Networking).