Wireless Network Service Degradation

Incident Report for HUIT

Resolved

HUIT Networking has resolved the issue impacting wireless network connections. If you continue to experience issues please contact the HUIT Service Desk via 617-495-7777 or email ithelp@harvard.edu
Posted Sep 04, 2025 - 11:17 EDT

Investigating

HUIT Networking teams are aware of and investigating an issue with Harvard wireless networks. We have engaged our vendor for additional support. While some users may experience occasional short disconnects or slow load times, overall service remains stable. When possible, switch to a wired connection if you are experiencing wireless network issues.
Posted Sep 03, 2025 - 16:10 EDT
This incident affected: Network Services (Wireless Networking).