Google Service Degradation
Incident Report for HUIT
Resolved
Google services are back to normal
Posted Dec 15, 2020 - 19:17 EST
Update
We are continuing to investigate this issue.
Posted Dec 15, 2020 - 18:55 EST
Investigating
Google services are currently experiencing issues. We are actively investigating the problem. Please visit the HUIT Service Status Dashboard for regular updates about this situation. We apologize for the inconvenience and hope to resolve this issue soon.
Posted Dec 15, 2020 - 18:49 EST
This incident affected: Email Services (Google Apps Gmail).