Campus Network Issues

Incident Report for HUIT

Resolved

Campus network connections have returned to normal operations.
Posted Oct 16, 2025 - 16:21 EDT

Monitoring

The network interruption was due to a brief outage from an upstream provider. All wired and wireless services have since stabilized. We will continue to monitor the situation.

If you continue to have issues, please contact the HUIT Service Desk at (617)495-7777 or by emailing ithelp@harvard.edu
Posted Oct 16, 2025 - 14:30 EDT

Update

Initial indications are that this is related to regional internet outage external to our network. We will continue to investigate and monitor the situation.
Posted Oct 16, 2025 - 14:10 EDT

Investigating

HUIT is aware of intermittent network disruptions across campus. Networking teams are investigating and we will provide an update as soon as more information is available.
Posted Oct 16, 2025 - 13:52 EDT
This incident affected: Network Services (VPN, Wired Networking, Wireless Networking).