Canvas Service Degradation
Incident Report for HUIT
Resolved
Canvas services are back to normal.
Posted Oct 29, 2020 - 13:12 EDT
Investigating
Canvas is currently experiencing issues. HUIT is aware and actively investigating the problem.
Posted Oct 29, 2020 - 12:25 EDT
This incident affected: Canvas.