Qualtrics service degradation
Incident Report for HUIT
Resolved
The degraded performance that caused users to experience delays in data ingestion (e.g. dashboards not loading) and inability to export data has been resolved. The root causes were identified and remedied. Some users may continue to experience a delay in data ingestion as the system works through the backlog of ingestion requests. However, data exports are now functioning properly.
Posted May 16, 2022 - 16:06 EDT
Identified
Our vendor has indicated that "The root cause of this issues has been identified and is being remedied."

Via https://www.qualtrics.com/status/
Posted May 16, 2022 - 10:47 EDT
Investigating
Qualtrics survey software is experiencing degraded performance regarding all data across their data centers. Dashboards aren't loading and exporting data is affected.
Posted May 16, 2022 - 10:45 EDT
This incident affected: Teaching & Learning Platforms (Qualtrics).