Canvas currently operational; HUIT is continuing to closely monitor

Incident Report for HUIT

Resolved

As of this morning, the Canvas platform is accessible to Harvard users.
If you any encounter any issues with Canvas, please contact the HUIT Service Desk: https://www.huit.harvard.edu/get-help
Posted May 08, 2026 - 12:11 EDT

Monitoring

As of this morning, the Canvas platform is accessible to Harvard users.

Instructure—parent company of Canvas—has stated the cyber incident is now contained: https://www.instructure.com/incident_update

HUIT will continue to closely monitor this incident and Canvas system stability. If you any encounter any issues with Canvas, please contact the HUIT Service Desk: https://www.huit.harvard.edu/get-help
Posted May 08, 2026 - 07:00 EDT

Update

The Canvas platform continues to be unavailable. Instructure is continuing to investigate and work toward resolution. We will post updates here as new information becomes available.
Posted May 07, 2026 - 20:30 EDT

Investigating

HUIT is aware that the Canvas platform is currently unavailable due to a cyber incident. This incident is understood to impact many Instructure customers worldwide and is not specific to Harvard. We will post updates here as new information becomes available.
Posted May 07, 2026 - 16:33 EDT
This incident affected: Canvas.