Slack Performance Issues
Incident Report for HUIT
Resolved
Slack has restored the service to normal operation as of 7PM
Posted Oct 05, 2020 - 19:33 EDT
Update
Slack are continuing to work to resolve these issues.
Posted Oct 05, 2020 - 16:49 EDT
Update
The errors are declining, though customers may not see any changes yet. Slack team is still continuing the investigation.
Posted Oct 05, 2020 - 15:28 EDT
Update
Per Slack, they are seeing signs of improvement, but users may still be seeing slow performance.
Posted Oct 05, 2020 - 13:44 EDT
Investigating
Some users are experiencing degraded performance across devices, specifically around sending messages or API calls. HUIT is investigating.
Posted Oct 05, 2020 - 11:51 EDT
This incident affected: Teaching & Learning Platforms (Other Teaching & Learning Platforms).