LXP Service Degradation

Incident Report for HUIT

Resolved

This issue has been resolved. If you continue to experience issues, please contact HUIT Service Desk (617)495-7777 or ithelp@harvard.edu.
Posted Dec 08, 2025 - 11:55 EST

Investigating

LXP is currently experiencing intermittent issues. We are actively investigating the problem. Please visit the HUIT Service Status Dashboard for regular updates about this situation. We apologize for the inconvenience and hope to resolve this issue soon.
Posted Dec 08, 2025 - 11:35 EST
This incident affected: Teaching & Learning Platforms (Learning Experience Platform (LXP)).